Op Elektronicaforum.nl is de kans om een antwoord op je vraag te krijgen heel groot. In overzichtelijke subcategorieën kun je vragen en antwoorden over elektronica zoeken, plaatsen en beantwoorden.
Elektronica Forum is onderdeel van Schakelingen Online
 


 
K8055, DC-motor, L298N

 
Plaats nieuw bericht   Plaats Reactie    Schakelingen Online Forum Index -> School en huiswerk vragen
Auteur Bericht
Giell



Geregistreerd op: 6-6-2009
Berichten: 12

BerichtGeplaatst: Za 6 Jun 2009, 12:38    Onderwerp: K8055, DC-motor, L298N Reageer met quote

Hallo,

ik moet voor mijn GIP een DC motor links en rechts laten draaien met een K8055 bordje. Dit mbv een H-brug.
Nu heb ik de L298N op een printje gesoldeerd, en aangesloten volgens volgend schema:
-Pin2, Output 1: naar DC motor
-Pin3, Output 2: naar DC motor
-Pin4, Vs: naar 12V voeding (voor DC motor)
-Pin5, Input 1: naar digitale uitgang 5 van K8055 bordje
-Pin6, Enable A: naar digitale uitgang 7 van K8055 bordje (constant hoog)
-Pin7, Input 2: naar digitale uitgang 6 van K8055 bordje
-Pin8, Ground: naar ground van K8055 bordje (hier komt ook de ground van de 12V voeding aan)
-Pin9, Vss: ook naar digitale uitgang 7 van K8055 bordje (weet niet of dit juist is?)

Maar de motor wilt niet draaien, de L298N wordt ook niet warm ofzo, er gebeurd gewoon niets?
Ik heb de digitale uitgangen 5 en 7 hoog gemaakt maar hij doet niets.
Mischien iemand een idee hoe ik dit zou kunnen oplossen?
Alvast heel hard bedankt!

Verder heb ik op het K8055 bordje ook nog een stappenmotor hangen, en die werkt perfect, ook met de 12V voeding.

Bedankt, Giel
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
stynus
Moderator
Moderator


Geregistreerd op: 16-5-2003
Berichten: 5787
Woonplaats: Overpelt (België)

BerichtGeplaatst: Za 6 Jun 2009, 12:44    Onderwerp: Reageer met quote

Vss moet aan 5V hangen
_________________
Met vriendelijke groet,
Stynus
http://www.elektronicastynus.be

--> Elektronica bouwpakketten en componenten te koop. <--
Naar boven
Bekijk gebruikers profiel Stuur privé bericht Bekijk de homepage
Giell



Geregistreerd op: 6-6-2009
Berichten: 12

BerichtGeplaatst: Za 6 Jun 2009, 12:46    Onderwerp: Reageer met quote

Moet ik hiervoor dan nog een andere voeding hebben?
Want het K8055 bordje levert alleen maar een hoog of laag signaal, dus geen 5V zeker?
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
stynus
Moderator
Moderator


Geregistreerd op: 16-5-2003
Berichten: 5787
Woonplaats: Overpelt (België)

BerichtGeplaatst: Za 6 Jun 2009, 12:52    Onderwerp: Reageer met quote

Ergens 5V aftakken van het K8055 bordje. En je hebt de massa's van de 2 schakelingen toch doorverbonden?
_________________
Met vriendelijke groet,
Stynus
http://www.elektronicastynus.be

--> Elektronica bouwpakketten en componenten te koop. <--
Naar boven
Bekijk gebruikers profiel Stuur privé bericht Bekijk de homepage
Giell



Geregistreerd op: 6-6-2009
Berichten: 12

BerichtGeplaatst: Za 6 Jun 2009, 12:55    Onderwerp: Reageer met quote

Ok, euhm de massa van de 12V voeding, die van het K8055 bordje, en die van de H brug heb ik samengehangen. Goed?
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Giell



Geregistreerd op: 6-6-2009
Berichten: 12

BerichtGeplaatst: Za 6 Jun 2009, 13:05    Onderwerp: Reageer met quote

Heb nu de massa van de 12V voeding aan de ground van het K8055 bordje gehangen. Daarbij hangt ook de massa van de (voorlopige) externe 5V voeding aan de ground van het K8055 bordje. En dan hangt de ground van de L298N nog aan de ground van het K8055 bordje.

Heb de L298N nu gevoed met externe 5V voeding en doet nog niets? =/
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
stynus
Moderator
Moderator


Geregistreerd op: 16-5-2003
Berichten: 5787
Woonplaats: Overpelt (België)

BerichtGeplaatst: Za 6 Jun 2009, 13:16    Onderwerp: Reageer met quote

Maak eens een schema ervan.Dat is wat overzichtelijk. Van die L298 wel alle pinnen tekenen.
_________________
Met vriendelijke groet,
Stynus
http://www.elektronicastynus.be

--> Elektronica bouwpakketten en componenten te koop. <--
Naar boven
Bekijk gebruikers profiel Stuur privé bericht Bekijk de homepage
Giell



Geregistreerd op: 6-6-2009
Berichten: 12

BerichtGeplaatst: Za 6 Jun 2009, 13:23    Onderwerp: Reageer met quote

Hier is een schema:

http://img222.imageshack.us/my.php?image=schemal298n.jpg

Zo heb ik het aangesloten, alleen dan dat pin 9 nu op 5V hangt, en dat ik niet de DAC uitgangen, maar de gewone digitale uitgangen gebruikt heb.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
stynus
Moderator
Moderator


Geregistreerd op: 16-5-2003
Berichten: 5787
Woonplaats: Overpelt (België)

BerichtGeplaatst: Za 6 Jun 2009, 15:47    Onderwerp: Reageer met quote

Verbind current sensing A ook even met de massa.

En waarom gebruik je analoge poorten voor die 2 ingangen van de L298? Die verwachten digitale signalen.
_________________
Met vriendelijke groet,
Stynus
http://www.elektronicastynus.be

--> Elektronica bouwpakketten en componenten te koop. <--
Naar boven
Bekijk gebruikers profiel Stuur privé bericht Bekijk de homepage
Giell



Geregistreerd op: 6-6-2009
Berichten: 12

BerichtGeplaatst: Di 9 Jun 2009, 18:11    Onderwerp: Reageer met quote

Doet nog niets dan..
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
stynus
Moderator
Moderator


Geregistreerd op: 16-5-2003
Berichten: 5787
Woonplaats: Overpelt (België)

BerichtGeplaatst: Di 9 Jun 2009, 19:44    Onderwerp: Reageer met quote

Stuur je de enable ingang wel aan?
_________________
Met vriendelijke groet,
Stynus
http://www.elektronicastynus.be

--> Elektronica bouwpakketten en componenten te koop. <--
Naar boven
Bekijk gebruikers profiel Stuur privé bericht Bekijk de homepage
marten77



Geregistreerd op: 31-7-2006
Berichten: 86
Woonplaats: noordwijkerhout

BerichtGeplaatst: Di 30 Jun 2009, 6:30    Onderwerp: Reageer met quote

Hallo Giel,

Van uitgaande dat de voeding nu correct is...

Als je de motor wilt laten draaien, dan moet je het volgende uitsturen:
Enable-A = hoog
Input-1 = hoog
Input-2 = laag

Wil je de andere kant op draaien:
Enable-A = hoog
Input-1 = laag
Input-2 = hoog

Als beide Inputs op hoog of laag staan, zal de motor stil blijven staan !
Dit staat ook aangegeven in een tabelletje, in de datasheet.

Succes...
_________________
Greetz,
Marten
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Plaats nieuw bericht   Plaats Reactie    Schakelingen Online Forum Index -> School en huiswerk vragen Tijden zijn in GMT + 2 uur
Pagina 1 van 1                     

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen
Je mag geen reacties plaatsen
Je mag je berichten niet bewerken
Je mag je berichten niet verwijderen
Ja mag niet stemmen in polls
Je mag geen attachments plaatsen in dit forum
Je mag bestanden downloaden in dit forum


Powered by phpBB © 2001, 2002 phpBB Group and phpBB SEO