Op Elektronicaforum.nl is de kans om een antwoord op je vraag te krijgen heel groot. In overzichtelijke subcategorieën kun je vragen en antwoorden over elektronica zoeken, plaatsen en beantwoorden.
Elektronica Forum is onderdeel van Schakelingen Online
 


 
probleem met PICKIT2

 
Plaats nieuw bericht   Plaats Reactie    Schakelingen Online Forum Index -> Digitaal
Auteur Bericht
bertus
Moderator
Moderator


Geregistreerd op: 14-2-2007
Berichten: 2253
Woonplaats: Amsterdam

BerichtGeplaatst: Za 18 Aug 2007, 18:46    Onderwerp: probleem met PICKIT2 Reageer met quote

Hallo,

Ik wil mij ook eens op de pics storten en heb daarom een PICKIT2 startterkitje gekocht met een 16F690 erbij.
Als ik MPLAB IDE opstart gaat het nog goed.
Als ik echter een lesfile van de pk2 laad krijg ik de volgende foutmelding :
File Time Warning : The parameter is incorrect , in een popup.
Als ik quickbuild uitvoer krijg ik de volgende mede delingen te zien :
Clean: Deleting intermediary and output files.
Clean: Deleted file "C:\PK2 Lessons\LPC Demo Board\01 Hello World\Hello World.mcs".
Clean: Done.
Executing: "C:\Program Files\Microchip\MPASM Suite\MPAsmWin.exe" /q /p16F690 "Hello World.asm" /l"Hello World.lst" /e"Hello World.err"
Message[302] C:\PK2 LESSONS\LPC DEMO BOARD\01 HELLO WORLD\HELLO WORLD.ASM 36 : Register in operand not in bank 0. Ensure that bank bits are correct.
Loaded C:\PK2 Lessons\LPC Demo Board\01 Hello World\Hello World.COD.
BUILD SUCCEEDED: Sat Aug 18 18:41:42 2007

De file waarmee ik het test is bijgevoegd als attachment.
Door de .txt eraf te halen krijg je de orginele terug.

Doe ik iets fout of vergeet ik wat ?

Groeten,
Bertus
_________________
Je hoeft niet alles te weten,als je het maar weet te vinden.
Als je iets vraagt lijk je misschien dom.
Als je niets vraagt blijf je dom.

Ik beantwoord geen vragen in PM's.
Dit gaat voorbij aan de ideeen van het forum,
het delen van informatie.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Mat Janssen
Moderator
Moderator


Geregistreerd op: 10-12-2003
Berichten: 11200
Woonplaats: nederweert

BerichtGeplaatst: Za 18 Aug 2007, 20:41    Onderwerp: Reageer met quote

Je hebt goto $ staan maar er is geen $ te vinden
_________________
signature ruimte te huur Wink
Verhuurd Exclamation
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
bertus
Moderator
Moderator


Geregistreerd op: 14-2-2007
Berichten: 2253
Woonplaats: Amsterdam

BerichtGeplaatst: Za 18 Aug 2007, 20:54    Onderwerp: Reageer met quote

Hallo,

Het is niet de "goto $" , dit betekent goto zelfde lijn (loop) (dit is regel 39)

De fout treed een paar regels eerder op (regel 36) dus bij "make pin c0 output"

Wat kan het zijn ?
Het heeft iets te maken met "Register in operand not in bank 0. Ensure that bank bits are correct. "

Groeten,
Bertus
_________________
Je hoeft niet alles te weten,als je het maar weet te vinden.
Als je iets vraagt lijk je misschien dom.
Als je niets vraagt blijf je dom.

Ik beantwoord geen vragen in PM's.
Dit gaat voorbij aan de ideeen van het forum,
het delen van informatie.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
Mat Janssen
Moderator
Moderator


Geregistreerd op: 10-12-2003
Berichten: 11200
Woonplaats: nederweert

BerichtGeplaatst: Za 18 Aug 2007, 21:00    Onderwerp: Reageer met quote

Kijk eens in de datasheet of het tris register wel in bank 1 zit !! Misschien zit het tris register wel in bank 0.
_________________
signature ruimte te huur Wink
Verhuurd Exclamation
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
bertus
Moderator
Moderator


Geregistreerd op: 14-2-2007
Berichten: 2253
Woonplaats: Amsterdam

BerichtGeplaatst: Zo 19 Aug 2007, 16:56    Onderwerp: Reageer met quote

Hallo,

Het TRISC register zit inderdaad in bank 1 of bank 3.
Ik heb diverse dingen geprobeerd om dit aan te spreken (o.a. met banksel en de rp1 en rp0 bits van het status register) maar ik kom niet verder.
Nog suggesties ?

Groeten,
Bertus

Het antwoord is gevonden !! de error is geen error maar een waarschuwing !!

Zie ook het microchip-forum :
http://forum.microchip.com/tm.aspx?m=32596&mpage=1
_________________
Je hoeft niet alles te weten,als je het maar weet te vinden.
Als je iets vraagt lijk je misschien dom.
Als je niets vraagt blijf je dom.

Ik beantwoord geen vragen in PM's.
Dit gaat voorbij aan de ideeen van het forum,
het delen van informatie.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
teraguppie



Geregistreerd op: 4-10-2007
Berichten: 1

BerichtGeplaatst: Do 4 Okt 2007, 12:03    Onderwerp: Reageer met quote

Net hetzelfde gehad met een vellemankitje (8048)
Schijnt een aardigheidje van de compiler te zijn.
Met de volgende regels ergens bovenin de code kan je het onderdrukken.

; following errorlevel directive for mplab
ERRORLEVEL -302 ;remove message about using proper bank

Zorg er dan wel voor dat je zelf de bankselectie in de gaten houdt.
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
stynus
Moderator
Moderator


Geregistreerd op: 16-5-2003
Berichten: 5801
Woonplaats: Overpelt (België)

BerichtGeplaatst: Do 4 Okt 2007, 13:02    Onderwerp: Re: probleem met PICKIT2 Reageer met quote

bertus schreef:
C:\PK2 LESSONS\LPC DEMO BOARD\01 HELLO WORLD\HELLO WORLD.ASM


Dat pad is wel erg lang.
Probeer het is in C:\test\ ofzo te zetten.
Ik kreeg namelijk ook allemaal vage foutmeldingen toen ik het pad te lang had (max 36 tekens meen ik)
_________________
Met vriendelijke groet,
Stynus
http://www.elektronicastynus.be

--> Elektronica bouwpakketten en componenten te koop. <--
Naar boven
Bekijk gebruikers profiel Stuur privé bericht Bekijk de homepage
Hedalen



Geregistreerd op: 17-10-2015
Berichten: 85
Woonplaats:

BerichtGeplaatst: Zo 4 Nov 2018, 16:07    Onderwerp: Reageer met quote

de pickit2 gebruikt normaal 5 draden, maar is 3 niet genoeg bij isp programmeren, want de vdd en de vss zitten er dan toch al op?
Naar boven
Bekijk gebruikers profiel Stuur privé bericht
stynus
Moderator
Moderator


Geregistreerd op: 16-5-2003
Berichten: 5801
Woonplaats: Overpelt (België)

BerichtGeplaatst: Ma 5 Nov 2018, 22:49    Onderwerp: Reageer met quote

De GND heb je nodig omdat je anders geen referentie hebt voor je spanningen. De +5V heb je nodig omdat de programmer zo kijkt welke spanning er op de print gebruikt wordt en zijn programmeer lijnen de spanning daarop aanpast.
_________________
Met vriendelijke groet,
Stynus
http://www.elektronicastynus.be

--> Elektronica bouwpakketten en componenten te koop. <--
Naar boven
Bekijk gebruikers profiel Stuur privé bericht Bekijk de homepage
Plaats nieuw bericht   Plaats Reactie    Schakelingen Online Forum Index -> Digitaal Tijden zijn in GMT + 2 uur
Pagina 1 van 1                     

 
Ga naar:  
Je mag geen nieuwe onderwerpen plaatsen
Je mag geen reacties plaatsen
Je mag je berichten niet bewerken
Je mag je berichten niet verwijderen
Ja mag niet stemmen in polls
Je mag geen attachments plaatsen in dit forum
Je mag bestanden downloaden in dit forum


Powered by phpBB © 2001, 2002 phpBB Group and phpBB SEO